Joining GLV-IX

GLV-IX is open to anyone who meets the GLV-IX Member requirements. GLV-IX requires member to be on of:

  • Internet Services Provider (ISP) based and registered in Latvia and providing internet services to customers in Latvia
  • Latvian state institution or municipality
  • Latvian state-owned enterprise
  • Business entity registered and operating in Latvia and providing services to customers in Latvia
To join GLV-IX, connecting entity must:
  • Possess its own publicly routable Autonomous System Number and classes of publicly routable networks obtained from a Regional Internet Registry (RIR)
  • Submit the Connection Request to GLV-IX operator
  • Submit any documents required to certify that the Connecting Entity has the necessary requirements for connection to GLV-IX
  • Meet all relevant GLV-IX Member requirements outlined in GLV-IX Policy
  • Must possess a border router capable with handling sufficient amount of routes
To join GLV-IX, connecting entity must provide:
  • AS-number of the connecting entity
  • AS-SET that includes the member AS and all respective customer AS-SETs/AS-numbers, but excludes uplink/transit/peer AS numbers (AS-SET is optional if only member AS prefixes are to be announced)
  • Maximum number of prefixes expected to be announced at the GLV-IX (with headroom)
  • The desired physical interface specifications and amount at each GLV-IX POP member wants to connect
  • NOC Details (if connecting entity is ISP) (Business hours phone number, 24/7 phone number, e-mail, support website)
  • Technical contact details (e-mail, phone number)
  • Administrative details of the connecting entity:
    • Company legal name
    • Company registration number (if applicable)
    • Public website
    • Address
    • Administrative contact (e-mail, phone number)
Requests to join GLV-IX can be sent to e-mail info@glv-ix.lv

Connection specifications

Members are required to connect using single mode fiber connection, as will be required by GLV-IX operator during the setup process. If any additional equipment is located in GLV-IX racks, it must be clearly labeled as belonging to that specific member. Cabling and equipment installation in GLV-IX racks will only be done by the operator of the exchange. Members have to inform GLV-IX operator of any devices between GLV-IX switches and members routers terminating the eBGP sessions over the peering LAN. GLV-IX operator expects to be notified of media converters or any other third-party equipment/providers used to connect to GLV-IX. Members can connect with single port or multiple ports (LACP bundle) in every PoP. Only links in same PoP with same speed can be bundled in single logical interface. Only dynamic bundles trough LCAP (802.3ad) are supported. Per flow load-balancing is performed.

GLV-IX uses access mode ports by default. Trunk ports can be used if specified. VLAN 1918 is used for the peering VLAN. VLAN mapping/translation can be used if specified.

Members must ensure their equipment is configured in such a way that a frame received from an GLV-IX port is never forwarded back to the exchange. In order to prevent any issues, no spanning-tree frames including Bridge Protocol Data Units (BPDU) should ever be sent to GLV-IX. All frames sent must have the same source MAC address. Members equipment must respond to ARP requests for one MAC address only. GLV-IX will filter traffic from unregistered MAC addresses. No equipment connected to Peering LAN is allowed to proxy-arp.

Members must use the IP address and netmask on Peering VLAN provided by GLV-IX operator and no others. The only L3 routing protocol allowed on peering LAN is BGP (as defined by RFC 4271 and later). All routes advertised across the Peering LAN(s) by members must point to the router advertising. AS Numbers used on the peering LAN must not be from ranges reserved for private use, unless the router using this AS Number is not announcing any routes. IP space used to number the LAN must not be advertised to other networks.

Port traffic limitations

Maximum MTU supported is 9000 bytes. Frames exceeding this payload may be dropped without further notice.

Allowed ethertypes are: IPv4 (0x0800), IPv6 (0x86dd), ARP (0x0806) and 802.3ad – LACP (0x8809). Traffic with any other ethertype may be dropped without notice.

Spanning Tree & BPDUs are ignored and dropped. GLV-IX infrastructure will not send or forwards BPDUs towards its members.
Broadcast and multicast traffic ir dropped with the exception of ARP and ICMPv6-ND.
No more than 0.1% of interface traffic can be broadcast, multicast or unknown unicast (Layer 2).
ICMP redirects are not allowed and will be dropped.

Members are not allowed to exchange internal traffic between their own connections within GLV-IX. Traffic shall not be routinely exchanged between two member interfaces connected to peering LAN and owned by the same member.

Recommended Cisco Configuration

Global configuration

no service dhcp
no ip bootp server
no service config
no lldp run
no cdp run

Interface configuration

interface GigabitEthernetx/x
  no ip redirects
  no ip proxy-arp
  no cdp enable
  no ip directed-broadcast
  no mop enable
  no negotiation auto
  duplex full
  no keepalive

Layer 2 Interface configuration

vtp mode transparent
spanning-tree mode pvst
spanning-tree extend system-id
no spanning-tree vlan 1918

vlan 1918
 name GLV-IX-LAN1

interface GigabitEthernetx/x
  description Interface to GLV-IX
  switchport access vlan 1918
  switchport mode access
  switchport nonegotiate
  spanning-tree bpdufilter enable
  speed nonegotiate
  no keepalive
  no cdp enable
  udld port disable
  no lldp receive
  no lldp transmit

Cisco IOS aggregated links (Bundles)

interface Port-channel1
 description GLV-IX aggregated bundle
 ip address yyy.yyy.yyy.yyy 255.255.255.0
 no ip redirects
 no ip proxy-arp
 no keepalive

 interface GigabitEthernet1/1
 description GLV-IX Link 1
 no ip address
 no ip redirects
 no ip proxy-arp
 no keepalive
 no cdp enable
 no lldp receive
 no lldp transmit
 channel-group 1 mode on

Layer 3 Interface configuration

interface Vlan1918
 description GLV-IX
 ip address yyy.yyy.yyy.yyy 255.255.255.0
 no ip redirects
 no ip proxy-arp
 no keepalive

IPv6 configuration recommendations

no ipv6 mld router
no ipv6 mfib forwarding
ipv6 nd suppress-ra
ipv6 nd ra suppress
ipv6 nd ra suppress all
no ipv6 pim
no ipv6 mld snooping